Compiling PostGIS/Postgresql on Ubuntu Feisty/7.04. Found in mailing-list.

thanks all ,,, i find the solution to compile postgresql 8.2.4 with postgis-1.2.1 on ubuntu-7.04 feisty

first i have to compile geos from (http://geos.refractions.net/)
./configure
make
make install
Make sure that /usr/local/lib is added to /etc/ld.so.conf
Make sure that you run /sbin/ldconfig afterwards

compile postgresql-8.2.4
./configure
gmake
su
gmake install
adduser postgres
mkdir /usr/local/pgsql/data
chown postgres /usr/local/pgsql/data
su - postgres
/usr/local/pgsql/bin/initdb -D /usr/local/pgsql/data
/usr/local/pgsql/bin/postgres -D /usr/local/pgsql/data >logfile 2>&1 &
/usr/local/pgsql/bin/createdb test
/usr/local/pgsql/bin/psql test

compile postgis-1.2.1
./configure --with-pgsql=/usr/local/pgsql/bin/pg_config
make
make install
su - postgres
createlang plpgsql yourdatabase
psql -f lwpostgis.sql -d your_database

done